Client Network Service Won't Start, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Client Network Service Won't Start, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 1 Follower

Guest posted on Thu, May 18 2006 12:17 PM
Hi,

On a Windows 2003 SP1 server running Presentation Server 4 with the latest patches the Client Network Service won't start. In the event log the following message is logged:

Event ID: 7003
The Client Network service depends on the following nonexistent service: Cdm

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

What is the CDM service? How do I install it? Has this happened to anyone before? Any help on this is much appreciated.
  • | Post Points: 20

All Replies

Guest replied on Thu, May 18 2006 10:41 PM
I am seeing this also on a PS4.0 server with W2K3 SP1 and the latest hotfixes (applied a few weeks. Ok. I've been busy setting up the default profile, using RDP up till now so hadn't really noticed th error. All I know is that Citrix clients cannot connect to this new server timing out after "Negotiating Capabilities". I'm going to try reinstalling PS4.0 on it this afternoon.

Phil
  • | Post Points: 5
Guest replied on Thu, May 18 2006 11:56 PM
Well - reinstalling the Presentation Server and Web Interface Components fixed the issue. (I removed, rebooted, then reinstalled the components, rebooted).
It must have been a microsoft update or some other piece of software which caused CDM to stop working. Weird. The first sympton I noticed was the ICA Client would take a long time Negotiating Cababilities. At first I thought it was licensing so I spent a lot of time checking that before finding it was simply the Client Network Service failing to start. Hope this helps. [:)]
  • | Post Points: 5
Not Ranked
Points 10
midosa replied on Mon, Apr 11 2011 6:38 AM

Hi, i have the same problem and solve like that

go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdm (create if not existing)

and under this key create the following values

DisplayName (REG_SZ) with value Cdm

ErrorControl (REG_DWORD) with Hex value 1

ImagePath (REG_SZ) with value \??\C:\Program Files\Citrix\system32\drivers\cdm.sys

Start (REG_DWORD) with Hex value 2

Type (REG_DWORD) with Hex value 2

Then restart the server..... should work !!!!

  • | Post Points: 5
Page 1 of 1 (4 items) | RSS