Presentation Server 4.0 License Problems, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Presentation Server 4.0 License Problems, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Not Answered This post has 0 verified answers | 5 Replies | 0 Followers

Top 25 Contributor
Points 9,400
Leonardo Curbelo Jr posted on Mon, May 1 2006 10:35 AM
I have a server farm of 50 servers, all Windows 2000 and Metaframe Presentation Server 4.0. All the servers have all the Microsoft Updates and Citrix hotfixes PSE400W2KR01 and PSE400R01W2K014. I have been seeing license errors in the Event Viewers of most of these servers in the farm

Event ID 9014 - The licenses required by this edition of MetaFrame Presentation Server are not present on the license server

followed by

Event ID 26 - Application popup: Citrix License Error : The licenses required by this edition of MetaFrame Presentation Server are not present on the license server

I can either fix the problem temporarily by either rebooting the server(s) with the licensing errors or by changing the licensing server name in the Management Console to a bogus server, clicking OK, and then setting the name again to the correct licensing server. Then the server's Event Viewer records an entry that the licensing server has been successfully contacted and that the server has left the grace period.

The Licensing Console shows the correct count and it also shows that there are plenty of licenses left.

The errors appear several times a day on some servers and every few days on other servers. There are some servers that do not have the error at all.

I am trying to make sense of this mess. I know that the Citrix hotfixes were released to correct licensing problems with the Citrix servers not returning the license to the licensing server but this seems to be a totally different variation of that problem. In any case, the hotfixes have been applied to all servers and this issue persists.

Has anyone encountered this problem before? Any help would be highly appreciated. Thank you.
  • | Post Points: 20

All Replies

Top 10 Contributor
Points 88,220
How long has this farm been up and running? Your licenses are for the correct version of Metaframe (advanced, standard, or enterprise)? You've confirmed that the servers are set correctly? The error ou are receiving has nothign to do with the amount of licenses but with what version of Metaframe your running.
  • | Post Points: 20
Top 25 Contributor
Points 9,400
Yes, everything checks out. The PS 4.0 Edition is Advanced. The Product Level and Code is set correctly for all the servers in the farm. This farm has been running for about 3 weeks now. The licensing server has the correct license file installed and all the licenses are advanced. Thank you for your help.
  • | Post Points: 20
Top 100 Contributor
Points 2,794
We had the same problem. Citrix recommended that we moved the license server to different servers in our farm but the problem remained. We have a farm of 120 servers and only 14 are experiencing this problem. The 14 servers that are experiencing this problem are in a separate subnet in an remote office. The Citrix license server is not local to these servers, so maybe we thought a bandwidth issue?? Wrong! We are using 4 digital T3 lines for a total of 155 MBit/sec. There is no way this bandwidth is not enough to transfer the license code stream. We thought maybe a port number issue??? Wrong! Our network engineers have opened all the ports (including port 27000 which is what the licensing service issues by default).
So... Citrix has no idea what is going on. The problem has been escalated and escalated and they still have no idea. According to them everything has been tried. Now they want to charge us $400/hr for developer support?? Yeah right! We worked out our own solution. Our developers wrote an application that monitors the Event Viewer for the following entries
"The licenses required by this edition of MetaFrame Presentation Server are not present on the license server"
Once this entry is found the application deletes the license server value from the registry and adds it again. Then the app changes another reg key to force the server to refresh the license. Then the application emails us all admins for us to know what server was refreshed. Not a very clean solution but it works for now. It beats the hell out of having to reboot the server.
If anyone has the solution for this, please help us. It is not a big issue to us anymore but it would be great to resolve this problem cleanly.
Thanks
  • | Post Points: 35
Guest replied on Wed, Jun 21 2006 10:30 AM
Im experiencing the same thing on one out of 16 machines in our PS 4.0 farm. It seemed to have just started yesterday, and ive verified that the metaframe edition is set correctly. The license server has 60 valid tickets out of which only half are in use, and no errors reflect this problem on the license server itself. As with the above post the affected machine is also at a remote site in a different subnet than the license server. Ill continue to reboot it until i can find out some more information... anyone's ideas are appreciated.
  • | Post Points: 5
Not Ranked
Points 25
Did anyone ever determine the cause/solution to this problem? We have been resettng the license server name in the cosole to re-create the mps-wsxica_mps-wsxica.ini file (which seems to grow when these errors occur)
  • | Post Points: 5
Page 1 of 1 (6 items) | RSS