SSL error 40, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

SSL error 40, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Not Answered This post has 0 verified answers | 6 Replies | 0 Followers

Guest posted on Thu, Nov 17 2005 2:10 PM
I am getting this error when I try to access the WI from either internal or external.

“Cannot connect to the Citrix server:
The Citrix SSL relay name could not be resolved (SSL error 40)”

Citrix says to resolve this try "create an entry in the host file on the client devices."

Can someone please post an example?

Thank you.

  • | Post Points: 35

All Replies

Top 150 Contributor
Points 1,360
The host file is located under your system32\drivers\etc directory. It is called hosts. There is a sample in the file (open with a text editor) that will guide you in adding a line to it. In your case, put your Citrix server host name and IP address in the file, and see if it clears your error.

Jeff Rudacille
  • | Post Points: 5
Top 10 Contributor
Points 88,220
Make sure the DNS name and the name associated with the SSL Certificate match.
  • | Post Points: 20
Top 200 Contributor
Points 1,570
JM replied on Wed, Jun 14 2006 10:46 AM
Well... The servername not matching the name on the certificate was my problem with the SSL Error 40.

However, now when I launch an application I get:

'Cannot connect to the citrix metaframe server. There is no Citrix Metaframe SSL server configured on the specified address'


Not sure what's going on at this point.
  • | Post Points: 5
Top 200 Contributor
Points 1,570
JM replied on Wed, Jun 14 2006 11:00 AM
Actually, got passed that error. I had port 80 not 443 in the Secure Gateway settings.

Now I'm getting SSL Error 29: The proxy denied access to abunchofnumbersandletters port 1494.

I think it might be a problem with some firewall rules.
  • | Post Points: 5
Guest replied on Thu, Dec 21 2006 1:23 PM
hi u need to made a entry in local machine hosts file.



Please verify that your Host file is same as below configuration.Try to modify it accordingly if you don't see the same.


your host file when opened should look like this:
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host
127.0.0.1 localhost
after this line in hosts file
127.0.0.1 localhost
make sure that the following line is added
140.12.136.10(your csg ip) citrixcsg.citrix.com .(ur csg fqdn name)
next save and close the file .Then try to access your EAS application.
To open the hosts file Click on start button on left bottom corner of your desktop and click on run .Then copy the following string in blue and press enter
c:\WINDOWS\system32\drivers\etc, then open the hosts file with notepad.

Please reply us with the status after you checked with the above procedure.
If the above configuration is available in your workstation.
try this next step:
1.Open the command prompt.Then copy the following string in blue to it and hit enter
telnet csg ip 443
If we see the following message :C:\telnet csg ip 443
Connecting To csg...Could not open connection to the host, on port 443
: Connect failed
It means that the port 443 is closed at your project site and needs to be opened by your local IT support.
when we don't see the above error message by copying telnet csg ip 443 to the command prompt .And could see only a blank cursor blinking.It shows that the port 443 is open.




vikram
  • | Post Points: 5
Page 1 of 1 (7 items) | RSS