MPS SP4 UH, OH!, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

MPS SP4 UH, OH!, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Not Answered This post has 0 verified answers | 47 Replies | 0 Followers

Top 500 Contributor
Points 811
Mike Lyon posted on Wed, Jan 19 2005 7:49 AM
Ok here goes, recently installed MPS SP4, maybe a coincendence but the day after the server stopped accepting connections. IMA service is stopped and WILL NOT start, server specific error code 2147090410. Checked the event viewer full of the following errors.
Event ID 3615: IMA_Result_Network_Failure.
Event ID:3609 Failed to load plugin ImaPsSs.dll
Event ID: 3609 Failed to load plugin IMARuntimeSs.dll with error -IMA_REsult_DBConnect_Failure
IMA service terminated server specific error code: 2147876886.
Have checked the plugin path in the reg and all paths OK to where the plugins are stored
Have tried dsmaint recreatelhc as a few net posts suggested this, however to no avail.
When trying to launch CMC following error: Failed to connect to prefered farm server
Oh have unistalled MPS SP4 and still not working!
Setup: Win2k SP3, MF XP FR3 Dell Poweredge Hardware
Thanks in advance
AJ
  • | Post Points: 80

All Replies

Guest replied on Fri, Nov 10 2006 10:23 PM
After SP4 upgrade I got following errors in event viewer.


The Independent Management Architecture service terminated with service-specific error 2147876886 (0x80060016).


Failed to load initial plugins with error IMA_RESULT_DBCONNECT_FAILURE


Failed to load plugin Imaadminss.dll with error IMA_RESULT_DBCONNECT_FAILURE


The Citrix MetaFrame XP Server failed to connect to the Data Store. Error - IMA_RESULT_NETWORK_FAILURE An unknown failure occurred while connecting to the database.

The following article fixed the issue

http://support.citrix.com/article/CTX109958&searchID=34236069



  • | Post Points: 5
Guest replied on Thu, Dec 28 2006 7:38 PM
ORIGINAL: Guest

I've had the same problem with a mixed XP and PS4 farm after I moved the datastore to a new SQL server, all but two of my XP servers worked fine, but the other two wouldn't start the IMA service.

Problem turned out to be that the ODBC file was configured to named pipes, changing this (using the advanced options) to TCP/IP fixed the problem.


My errors were identical to everyone else, except I was trying to install a new server and introduce it to the farm. IMA would never start and the install would roll back. I found several listings about timeout of the SCM in windows, but that wasn't the case for me. It was obvious that there was a communication problem. The above post from a guest reader is exactly what fixed my problem as well. Once the SQL connection was configured for TCP/IP instead of PIPES, it connected and started no problem. I can't believe I overlooked this. Thanks to the poster.
  • | Post Points: 5
Guest replied on Mon, Apr 2 2007 7:52 AM
I had an identical indicent, and after several hours of trying all what was suggested, it was fixed to copy the mf20.dsn from a good wroking server.
Then disabled the print spooler, this allowed to startup the IMA service successfully.

Kind regards Marino
  • | Post Points: 5
Page 4 of 4 (48 items) < Previous 1 2 3 4 | RSS