Access Management Console Issues, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Access Management Console Issues, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 9 Replies | 2 Followers

Not Ranked
Points 90
Michael posted on Wed, Oct 7 2009 11:27 AM

I've just recently installed the XenApp 5.0 AMC and PSC on my 32-bit Vista Business Edition laptop so that I can manage our 5.0 farm running on Server 2003 64-bit.  I have no issues installing but it seems that I receive the following error messages during the discovery process:

"The My Knowledge features will not be available for farm..."

"The RPC server cannot be contacted on server..."

I have researched these errors and haven't been able to find a solution thus far.  If I log onto my data collector I can pull up the discovery without issue, as well as on the WI server.  The only thing that can see that might be causing the issue is that the account under which the AMC runs is not an admin account on my Citrix servers, but it does have full administrator rights within the farm.

  • | Post Points: 35

All Replies

Top 10 Contributor
Points 48,811
Suggested by Dan Murray

One of two things may be going on here.  Either, you have a file called "mmc.exe.config" in your Windows\System32 folder and you should try deleting/renaming it.  Or, if the file doesn't exist, try creating a file called “mmc.exe.config” in the \Windows\system32 directory and add the following lines to the file. You should be able to open the Access Suite Console without any further problems.

<?xml version ="1.0"?>
<configuration>
       <startup>
            <requiredRuntime version="v1.1.4322"/>
            <supportedRuntime version="v1.1.4322"/>
       </startup>
</configuration>

Why is it called "Common Sense"? It doesn't seem all that common!

  • Post Points: 35
Not Ranked
Points 90

I don't have a "mmc.exe.config" file.  I'll create one and post back the results.

  • | Post Points: 5
Not Ranked
Points 90

Dan - This didn't work, it actually will not even load up the snap-in.

"MMC could not create the snap-in.

MMC could not create the snap-in.  The snap-in might not have been installed correctly.

       Name: Citrix Access Management Console

       CLSID:{C494A846-4DE9-446E-BFCE-21F7E7D23FEA"

 

 

  • | Post Points: 5
Not Ranked
Points 90

Once I delete the file I created the AMC opens back to where I originally was.

  • | Post Points: 5
Not Ranked
Points 45

Have you found a resolution - My farm is at 4.5, but I loaded the 4..6.5 AMC on my Windows 7 box and got it to load only to have the MMC close on me after a few minutes of being opened. 

 

thanks

 

 

Chris

  • | Post Points: 20
Not Ranked
Points 90

I wish that I could report back that I have.  I still am unable to discover my WI servers and the knowledge base is not available.  Outside of that I have been able to get it to run on Vista Business Edition SP2.  I'm going to install it now on my Windows 7 PC and see what I get.  How did you install the consoles, from the Administration directory?

  • | Post Points: 20
Not Ranked
Points 45

Downloaded the console from citrix  http://support.citrix.com/article/CTX122214

and installed it. I didn't have to do anything special to install it

  • | Post Points: 20
Not Ranked
Points 90
Michael replied on Tue, Oct 13 2009 10:48 AM

I've installed this AMC on my Windows 7 32-bit workstation and have had no issues with it.  I've noticed that this is a stripped down module compared to what I have installed on my Vista 32-bit laptop.  Previously on my laptop, I installed the AMC and PSC from the Administration directory off the XenApp 4.5 install media.  I installed the 4.6.5 AMC right on top of the laptop install and still have issues with the Knowledge Base and discovery of the WI servers. 

I don't understand why Citrix has removed some of the key features in the 4.6.5 AMC?  I would think that the reporting features are important enough to keep in it.  It seems that my only options at this point are to:

1. Run only the 4.6.5 AMC (without any previous install), and Run administration of the WI servers from the actual WI servers themselves.

2. Run a hybrid mix of a 5.0 AMC from the install media, with a 4.6.5 AMC install, but continue to loose the Knowledge Base and WI features.

3. Run all AMC capabilities from the DC and WI servers.

Thoughts?

  • | Post Points: 20
Not Ranked
Points 45

It might have to be a mix for now - I still have issues with the AMC not workking - it starts up and then crashes after a couple of minutes, I look at the WER reports, but they are useful at all to me

  • | Post Points: 5
Page 1 of 1 (10 items) | RSS