Help with event id 1526 "Windows did not load your roaming profile", in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Help with event id 1526 "Windows did not load your roaming profile", in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Answered (Verified) This post has 1 verified answer | 2 Replies | 1 Follower

Not Ranked
Points 45
bchit posted on Thu, Jul 9 2009 1:23 PM

We are running Presentation Server 4.5 with now almost 50 machines in our farm.

We get this in the event log (randomly) and sometimes 20 users in a day and sometimes just 5. Event ID: 1526

Windows did not load your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Windows did not load your profile because a server copy of the profile folder already exists that does not have the correct security. Either the current user or the Administrator's group must be the owner of the folder. Contact your network administrator.

 

We have tried using the xcacls from http://www.brianmadden.com/forums/t/26502.aspx for all users on the tsprofiles server and then deleting their profile on all 50 servers in \documents adn settings\%username% and that works for that user for a day, or even a week and then it starts over again.  Any ideas as to how to finally make this go away for good.  This is really getting annoying in farm of almost 50 servers and 2500 users. 

We do have a GPO that is setup as

 Administrative Templateshide
Policy definitions (ADMX files) retrieved from the local machine.System/Group Policyhide
Policy Setting Comment
User Group Policy loopback processing mode Disabled 

System/User Profileshide
Policy Setting Comment
Delete cached copies of roaming profiles Enabled 

Windows Components/Terminal Services/Terminal Server/Connectionshide
Policy Setting Comment
Set rules for remote control of Terminal Services user sessions Enabled

and also a redirect policy for the users with:

Windows Settingshide
Folder Redirectionhide
Documentshide
Setting: Basic (Redirect everyone's folder to the same location)hide
Path: \\meanserver\Private$\%USERNAME%\MyDocs
Optionshide
Grant user exclusive rights to Documents Disabled
Move the contents of Documents to the new location Disabled
Also apply redirection policy to Windows 2000, Windows 2000 server, Windows XP, and Windows Server 2003 operating systems Enabled
Policy Removal Behavior Restore contents

Musichide
Setting: Follow the Documents folder
Pictureshide
Setting: Follow the Documents folder
Videoshide
Setting: Follow the Documents folder

if that helps.  Please help! thanks!

 

 

 

  • | Post Points: 20

Answered (Verified) Verified Answer

Not Ranked
Points 45
Answered (Verified) bchit replied on Thu, Jul 16 2009 4:09 PM
Verified by bchit

Solved.  Here is the solution for all that wanted to know:

http://support.microsoft.com/kb/935649

This is solved by fixing the pagedpoolsize on all the servers.

Thanks to all for responding...

  • | Post Points: 25

All Replies

Top 25 Contributor
Points 14,654
Suggested by Mowens

Dare I say it's a feature:

http://support.microsoft.com/kb/327462/en-us

Basically use the "Do not check for user ownership of Roaming Profile Folders" GPO

--Emil

  • Post Points: 5
Not Ranked
Points 45
Answered (Verified) bchit replied on Thu, Jul 16 2009 4:09 PM
Verified by bchit

Solved.  Here is the solution for all that wanted to know:

http://support.microsoft.com/kb/935649

This is solved by fixing the pagedpoolsize on all the servers.

Thanks to all for responding...

  • | Post Points: 25
Page 1 of 1 (3 items) | RSS