RPC server unavailable, in the Terminal Services forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

RPC server unavailable, in the Terminal Services forum on BrianMadden.com

rated by 0 users
This post has 42 Replies | 2 Followers

Guest replied on Tue, Jul 18 2006 5:07 AM
If your using Samba as a PDC, make sure its runing. Windows 2003 gives the same error as suggested above if its can't use Samba to get authentication details.

In my case the (simple) following fixed it:

/etc/init.d/smb restart

...on SuSE.

-Andrew
  • | Post Points: 5
Guest replied on Thu, Oct 19 2006 12:47 PM
TCP/IP NetBIOS Helper was disabled for me...thanks so much for the fix. I was looking all over and checking group policies and dcomcnfg. This is also our IAS server and was causing EAP authentication failures with an event ID of 2 and reason code 48. We have cisco 1200 aironet WAPs. Enabled the helper service and all problems cleared up.

Reason = The connection attempt did not match any remote access policy.
  • | Post Points: 5
Guest replied on Wed, Nov 1 2006 1:14 AM
ORIGINAL: Guest

Hi all I had the same problem tonight :( turns out somebody had disabled the Client for Microsoft Networks![:@]

Murph


Thanks for the tip. This worked for me. Somehow it got turned off. When I re-enabled it, it works again. Strange thing is, the machine is running ISA 2004 and nobody logs onto the machine except me. Go figure. [sm=s231.gif]
  • | Post Points: 5
Guest replied on Thu, Nov 30 2006 9:30 AM
We just started seeing the same error when connecting via RDP. NetBIOS Helper is running, RPC is running, we just cannot logon to the server.

We can get to the files/shares without a problem -- whew.

Any other ideas?
  • | Post Points: 20
Guest replied on Thu, Nov 30 2006 2:46 PM
i have had this problem on various sites that use TS on W2k3.

generally the TS's run fine until suddenly, at seemingly random times, users can't logon & the winlogon/ rpc errors posted above are found in the event logs.

This can be weeks apart, or days or hours.

The environments are otherwise very stable so when suddenly users can't login, it's a big problem.

Also, it the problem goes away by itself after 10-20 minutes, so before I get a chance to really look at the problem it has resolved itself!!! Very frustrating.

Next time it happens I will try to login via mstsc x.x.x.x /console to the (this computer) rather than to the Domain... might try to ping "domain.local" also...

Anyone have any other ideas??? this is craziness.

Ty
Isaac.

  • | Post Points: 5
Guest replied on Thu, Nov 30 2006 11:42 PM
TCP/IP NetBIOS Helper was disabled on my Server, once it was set to Automatic and enabled it worked like a charm!!

Cheers guys!
  • | Post Points: 5
Guest replied on Thu, Feb 8 2007 9:42 PM
I too have this problem. After reading http://support.microsoft.com/kb/883670 it seemed like my problem howver this fix would not even apply to my system due to SP1 being installed. My Netbios Helper service is started as well.
  • | Post Points: 5
Guest replied on Sat, Mar 3 2007 3:28 PM
I changed my DNS settings to point to my internet DNS servers and had the problems, I changed them back to point to my own local DNS server on another 2003 server and my terminal services sessions work just fine again. Ha! teach me to change things!
  • | Post Points: 5
Guest replied on Mon, Mar 12 2007 12:37 PM
ORIGINAL: Guest

Hi,

First step
The name resolution must be working fine DNS/AD !

Second step
ipconfig /flushdns on the computer that u need gain access !

more nothing !

A hug

Cezar Renan (From OZ - Brazil) [:D]


This worked for me [:D]
  • | Post Points: 20
Top 10 Contributor
Points 48,651
No joy here! [:(] DNS = OK. AD = OK, tried every patch under the sun. Usually within 2 weeks at least one of our servers has the issue. Even Microsoft is scratching their heads. Any other ideas?

Why is it called "Common Sense"? It doesn't seem all that common!

  • | Post Points: 20
Guest replied on Sun, Apr 15 2007 3:17 PM
Ok, here is my story, hopefully it will shed some light on issues some other people might still be having. I checked all of the solutions listed in this forum and in others around the Internet, but nothing seemed to work. I did finally realize that it was an authentication error though, and I finally tracked down the one thing all the servers that were failing had in common. There was some archaic group policy that a former admin had setup which had set the "Microsoft Network Client:Digitally sign communications (if server agrees)" Security Policy to "disabled" In Active Directory the policy was preventing encrypted authentication between the member servers and the Domain Controllers, because the Domain Controllers were requesting, but not receiving Digital Signatures for authentication requests from these servers. I changed the policy to match the rest of the unaffected servers, ran a Group Policy update and rebooted the affected servers, and "Voila" it was fixed. I am not sure if anyone else will have the exact same configuration flaw as me, but it is definitely worth looking deeper into any type of authentication errors your affected servers may be experiencing when communicating with your Domain Controllers.
  • | Post Points: 5
Not Ranked
Points 5
Hugh replied on Fri, Feb 6 2009 3:58 AM

Make sure your NIC is set to either Default

or Enable Netbios over TCP in the WINS tab in the advance settings of the TCP/Ip properties of your NIC.

The service also needs to be running.

 

  • | Post Points: 5
Not Ranked
Points 25

RPC error was seen even when doing RDP to citrix server. Looking at Load Evaluator settings we seen userload parameter is added, removed this parameter and since then the RPC error is not seen.

in the event log you will see multiple 1219 error in application logs, this is the hint. UserLoad parameter of Load Evaluator is rejecting the next login to server.

Give a try and let me know if the issue is resolved after LE setting changed.

Thanks

Ahmad Irffan

  • | Post Points: 5
Page 3 of 3 (43 items) < Previous 1 2 3 | RSS