Protocol Driver Error, in the Client / End User Issues forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Protocol Driver Error, in the Client / End User Issues forum on BrianMadden.com

rated by 0 users
This post has 10 Replies | 0 Followers

Top 500 Contributor
Points 1,005
Josh Cayer Posted: Tue, Aug 2 2005 11:56 AM
All right experts, I have one user intermittently getting a Driver Protocol Error. PS3 on a Win 2003 box, pretty plain install. The user is using a WYSE 3125SE terminal. Here is where it gets shaky. She has a Cisco SOHO Router at her house that sets up a VPN between her home and our network over a cable modem.

We have 6 other users with this setup except DSL and they do not have this problem.

She can connect, does some work and then gets booted out with the Protocol Driver Error. She can sometimes get right back in, but usually ends up rebooting the terminal, the router, and the cable modem. After all that, sometimes she gets in, other times not. If she waits 15 minutes, her chances seem to increase.

Couple more tidbits: when she gets booted out, sometimes she's disconnected, other times, the connection is gone. Her terminal does not have any IP tools, so I cannot do a test ping or trace route.

Any ideas? Thanks in advance.
Josh
  • | Post Points: 35
Top 10 Contributor
Points 88,220
To start with:

Error: "1030 - Protocol Driver Error" Troubleshooting Steps and Suggestions
http://support.citrix.com/kb/entry!default.jspa?categoryID=122&externalID=CTX911130&fromSearchPage=true

Error: Cannot connect to the Citrix server. Protocol Driver Error and/or Transport Driver.
http://support.citrix.com/kb/entry!default.jspa?categoryID=149&externalID=CTX105793&fromSearchPage=true

Troubleshooting the Citrix XTE Service and Errors: There is no route to the specified address. and Protocol Driver Error
http://support.citrix.com/kb/entry!default.jspa?categoryID=618&externalID=CTX106531&fromSearchPage=true

  • | Post Points: 20
Guest replied on Tue, Aug 2 2005 12:26 PM
Thanks, not to sound like an idiot, but I did go to citrix.com and typed Protocol Driver Error in the search box and got no hits.

I did find a 2 of the 3 elsewhere online and they weren't any help. I'll try the other one...fingers crossed.
Thanks.
Josh
  • | Post Points: 5
Guest replied on Thu, Aug 25 2005 1:03 PM
Have you resolved your issue? I am receiving the same error although my environment is different. It is on an internal network and I have the application (desktop) set to auto-start. I get the error on 3360SE, 3150SE, and 3125SE thin clients. I have tried the various Citrix articles including increasing the idle winstation count, making sure session reliability is not checked, etc. It happens after numerous automatic reconnections, ie no one has signed in, session logs off, reconnects, and then I get the error.
  • | Post Points: 5
Guest replied on Sun, Aug 28 2005 6:34 AM
We get the same Error with PM4 , directly with PN installed on the Server (win2003 without SP1). On the Clients the error of course also appeaers.
So an idea beside the articels above would be great.
  • | Post Points: 20
Top 500 Contributor
Points 1,005
Sorry turns out the user network connection was the problem. It took the cable modem installers numerous calls, but they finally fessed up and sent someone out. Turns out her wire from the street can't handle all her TVs and the cable modem.
Josh
  • | Post Points: 20
Not Ranked
Points 130
Hello Everyone,

Well I’ve been struggling with this same error for weeks now. I’ve searched the web and Citrix’s web site and they offered little information about this error.

Before I explain how I resolved this issue, please let me lay out the troubleshooting process and general configuration details.

Configuration details:

• PS4
• WI version 4.0.45083
• SG version 3.0.0
• WI/SG on same server in DMZ
• Firewall used PIS 515E with 3 interfaces
• NAT entry from the public side to the WI/SG server on the DMZ
• Nat entry from my public interface to my WI/SG server.
• SG is listening on 443
• WI on 444
• All clients have ICA client version 9.00.32649

Problem manifestation:

User would log into a published application the first time, and everything would work great! If the client tried to reconnect to another published application or reconnect, then the connection would fail.

The connecting to “application name” would stall. Eventually, I would get an error “Protocol Driver Error”. This error would happen from internal/external users using SG. The only way to address the issue was to reboot the client.

As a final observation, not all clients were reporting this issue, only a small group of clients.

Observations:


Host Event ID Source
SG/WI 103 error Secure gateway
SG/WI 235 error Secure gateway
Client Nothing
STA Nothing
Citrix server Nothing

Troubleshooting steps:

• Audit counter errors on all the hosts involved
o STA1
o STA2
o WI/SG
o Every interface on the firewall
o Client port when connecting from the internal network
o Increased the error timeout duration on the PIX firewall

• Audited DNS and NAME resolution was OK

Basically, nothing worked!!!

As a last resort, I looked at the application/hardware list. I noticed that all the clients reporting the errors had Bluetooth capabilities. So for kicks, I disabled the Bluetooth device and the problem went away!

I don’t understand why but disabling this hardware worked.

Best regards






  • | Post Points: 5
Guest replied on Tue, Feb 7 2006 4:59 PM
To Jcayer, i have the same problem. I use the Cicatrix network for doing transcription. Sometimes can connect, sometimes can't. I run Windows XP. The computer guy that installed it told me I must have Adware installed, but I can't find any Adware on my computer. Is there a free software or website that would check your computer for it? I had this iwon copilot on my computer that I can't take off, would this affect the Cicatrix program?
  • | Post Points: 5
Guest replied on Tue, Feb 21 2006 7:59 PM
Well I really hope I can help everyone here as I know this has been an issue for a lot of people. We have been working on this one for a couple of days, and today we got the answer.

Our setup:
5 x PS 4.0 servers on LAN
1 x CSG\WI server in DMZ. Yes we have CSG and WI installed on the same box.
Clients: macs and Windows PC's
Session Reliability ON through default port (2598)
Verisign certs

Problem:
Protocol Driver error when attempting to launch apps from CSG/WI.

Resolution:
Two settings changed under Access suite console (ASC), under site components--configuration tools--web interface--
Setting 1:
1. Under the web site goto MANAGE SERVER FARMS. This window shows the farm and you can edit the farm. Press ADVANCED at the bottom of the dialog box.
2. In the new dialog box, UNTICK "enable socket pooling"
3. We also reduced the "socket timeout" under XML service communication to 10 seconds but I don't think this was critical.
4. Press OK, close the ASC and restart IIS

Setting 2:
This was a weird one but it gave us instant success when set.
1. Under the web site goto MANAGE SERVER FARMS. Choose the farm and press EDIT.
2. Under the ticketing section, ensure "enable ica authentication tickets" is TICKED.
3. Change "metaframe ticket time to live" to 30 seconds.
4. Press OK, close the ASC and restart IIS.

Now shorting the ticket time actually gave us instant success - no more protocol errors. We did see some cases where users would login to CSG\WI and instantly click on the published app, and they got the protocol driver error. However, they clearled the error, reselected the published app and got straight in everytime.

We timed this problem and found if the user logged in, waited 10 seconds or more, once the published apps were listed in CSG/WI, they got straight in. This could be replicated perfectly. We are currently seeing if it is just a timing issue on the network for this one.

The bottom line is however, this will fix this very annoying problem.

Regards

Warren Simondson

Ctrl-Alt-Del IT Consultancy

Email: warren@ctrl-alt-del.com.au

Website: http://www.ctrl-alt-del.com.au

Business Hours: +61 7 3848 0285 Mobile: 0400 699 733

  • | Post Points: 5
Guest replied on Wed, Feb 22 2006 8:15 AM
Nice one, i had the same problem and that last posted fix also resolved my problems. But then i changed oth these settings back it it still works. I did make a number of changes with regard to session sharing and wondered if this was also what you did prior to making these changes. Most of the documentation suggests its a session sharing issue. Either way its sorted now, so its definatley what you suggested above or session sharing is enabled and the ports arent open on the firewall for it to work.
  • | Post Points: 20
Top 200 Contributor
Points 1,320
This one really threw me.

I had found out that the "Protocol Error Driver Error" message is a red herring!

Turn off session reliabilty then you will get your true underlying error message.

Fix your problem, then turn it back on.

I hope this help.
Citrix Consultant
  • | Post Points: 5
Page 1 of 1 (11 items) | RSS