Launch.ica error, in the Citrix Web Interface forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Launch.ica error, in the Citrix Web Interface forum on BrianMadden.com

rated by 0 users
This post has 15 Replies | 2 Followers

Not Ranked
Points 235
Steen Okkels Norby Posted: Wed, Apr 6 2005 5:29 AM
Hi,

I've implemented a Citrix Secure Gateway solution - and I'm very happy about it, however, I've got one problem with a few users workstations. Instead of launching the application, I'm asked to save a launch.ica file to the workstations harddisk. Normally that's because there is no citrix-webclient installed on the workstation. However that's not the case, and it has been working. I can launch the application afterwards by clicking on the launch.ica file.

I tried to reinstall the the webclient, delete temp. internet files, cookies. Until now I've only seen the problem, when it's af windows xp workstation.

Can any one tell me what to do about these workstations ?
  • | Post Points: 95
Not Ranked
Points 345
Go to the browser (IE) internet Options on the workstation, Advanced & untick "Do not save encrypted pages to disk" option under security. That will resolve the issue.

Regards,
Vijay
Vijay
  • | Post Points: 5
Not Ranked
Points 80
Not wanting to start another thread for the same problem, I am recieving this same behavior. The problem is not the "do not save encrypted pages to disk". As we have that unchecked in GP. The prompt recieved does not allow "run", just "save" and "cancel". I know there is an IE security thing that is screwing me over, but I can't for the life of me find it. By chance have any of you experienced the same behavior?

XP SP2
IE6 SP1
PS 4.0

TIA,
Greg
  • | Post Points: 20
Top 25 Contributor
Points 9,258
Have you added your CSG site to the trusted sites in IE?
The New Zealand Citrix User Group - http://www.cug.co.nz
  • | Post Points: 5
Not Ranked
Points 80
Thanks for replying, it is set in the local intranet zone. and I have tried it allowing pretty much whatever to be open/allowed.
  • | Post Points: 20
Top 150 Contributor
Points 1,219
What error are you receiving? I had a similar issue that related to a certificate issue, but I believe it specifically mentioned the certificate in the error.

M. King

  • | Post Points: 20
Not Ranked
Points 80
No error really, just instead of launching the ica it prompts to either save or cancell (like it is downloading it).
  • | Post Points: 20
Top 25 Contributor
Points 9,258
What version of IE are you running?
The New Zealand Citrix User Group - http://www.cug.co.nz
  • | Post Points: 20
Not Ranked
Points 80
OS=XP SP2
Browser=IE6 SP1

Thanks
  • | Post Points: 20
Top 150 Contributor
Points 1,345
Just out of curiosity, what client type are you using?
To identify, before you log in on the web interface screen, click on Advanced Options and see what the client type is set to. Try using the Local Client.
  • | Post Points: 20
Guest replied on Thu, Jul 19 2007 10:43 PM
Did anyone find an answer for this? We're seeing the same thing.
  • | Post Points: 20
Not Ranked
Points 20
I ran into the same issue, checked settings (do not save encrypted pages to disk) and then discovered the ica client was not registered with the browser.
To resolve do the following;
Open a command prompt in the same directory wfica32 resides (i.e. C:\Program Files\Citrix\ICA Client) and run the following command;

wfica32 /setup

You’ll receive a response that registration was successful. Open browser window and login to citrix.
  • | Post Points: 20
Not Ranked
Points 5
Ramon replied on Tue, Oct 7 2008 11:41 AM
In internet explorer - click on tools - options - advance tab - scroll to the security settings -

Uncheck the box - “Do not save encrypted data to disk.”

-Cepedare
  • | Post Points: 5
Not Ranked
Points 5

Hi Eric,

    Thank you so much for your post regarding the "Launch.ICA" issue. I was also looking for an answer and had hit a proverbial brick wall. I had removed and reinstalled the Citrix client as well as completely duplicated all of the IE8 settings between a working PC and one that produced the "Save/Cancel" dialog box. It took me several searches before I found this forum and your specific post.

I expanded the steps for anyone who might need a bit of clarification:

1.       Open a command prompt with elevated privileges (local Admin)

2.       At the prompt type:

a.       For 32-bit Vista/Windows 7 or Windows XP: cd c:\program files\citrix\ica client and hit ENTER

b.      For 64-bit Vista/Windows 7: cd c:\program files (x86)\citrix\ica client and hit ENTER

3.       Type the following command:  wfica32 /setup and hit ENTER

4.       A message box should pop-up indicating that wfica32 has been successfully registered and to close all browser windows. Click OK, make sure all browser windows are closed.

5.       Restart the browser and logon to Citrix

Eric Everson:
I ran into the same issue, checked settings (do not save encrypted pages to disk) and then discovered the ica client was not registered with the browser.
To resolve do the following;
Open a command prompt in the same directory wfica32 resides (i.e. C:\Program Files\Citrix\ICA Client) and run the following command;

wfica32 /setup

You’ll receive a response that registration was successful. Open browser window and login to citrix.

  • | Post Points: 5
Not Ranked
Points 5

I've had this a few times when using new remote PCs to connect to the secure Citrix gateway at work. The solution's always the same for me:

1) Open the following URL in your browser:

http://www.citrix.com/site/ss/downloads/details.asp?downloadId=1681207&productId=186#top

2) Download & install the "XenApp Web Plugin" .msi file   (from what I've seen it doesn't matter where on your C:\ drive you install it)

3) Retry Citrix access and it should work now

  • | Post Points: 5
Page 1 of 2 (16 items) 1 2 Next > | RSS