Application Hangs, in the Application Installation & Compatibility forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Application Hangs, in the Application Installation & Compatibility forum on BrianMadden.com

rated by 0 users
This post has 16 Replies | 0 Followers

Top 150 Contributor
Points 2,098
don thompson Posted: Tue, Jan 30 2007 5:12 PM
CPS4.0 RO2.0.1
Windows Server 2003 SP1
We use a shared desktop, and throughout all the event viewer of our small citrix farm, I see random Application Hangs. They are either Event Id 1002, or 1000. They generally read:

Hanging application winword.exe, version 10.0.6612, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

Others are the same except instead of winword.exe, we get excel.exe ver 10.0.6501.0, or iexplore.exe ver 6.0.3790.1830, or even wpwin9.exe ver 9.0.0.883. Just today i found a couple new ones: winword.exe ver 10.0.6612.0, faulting module mso.dll ver 10.0.6626.0 fault address 0x00023ecd, and winword.exe ver 10.0.6612.0, faulting module vbe6.dll ver 6.4.99.69, fault address 0x000b0d85.

I don't get as many help desk calls as the hangs, so I am assuming it is not crashing the app every time I see the error. I checked the ctfmon.exe (MS Q282599) and my setting have the Alt User Input Svcs as not available. And, there is no ctfmon.exe service running in the task manager.

Anyone have an instant fix for me? [:D] Of course, advice would be great too!!!

Tahnks
  • | Post Points: 50
Not Ranked
Points 210
I am also experiencing the same issues. Any help would be appreciated.

Thanks,

Jeff Venier
Jeff Venier
Network Administrator
  • | Post Points: 20
Not Ranked
Points 275
I have the same issue. And no users complaining about applications crashes. I thik that the problem apperes when users are opening documents inside IE and try to save the document. But its just a guess. Im current try to reproduce the problem.
  • | Post Points: 20
Guest replied on Wed, Feb 14 2007 5:38 PM
Same issue here. we have some apps that use Word as its spell checker. We recently applied all of the latest Citrix hotfixes (we are on x64). the events began about 2 weeks after patching.

Apphangs are very frustrating to troubleshoot as we are seeing about 1 per 5 users per day which basically means it is impossible to reproduce.
  • | Post Points: 5
Guest replied on Fri, Mar 9 2007 10:55 AM
I have a support case with Microsoft open and it has been escalated up to their 3rd level after over a week of getting bounced around on the phone. I will keep you posted with any fixes.
  • | Post Points: 20
Top 150 Contributor
Points 2,098
Awesome! THX
  • | Post Points: 20
Top 10 Contributor
Points 88,220
had this same exact issue at a client one time, brought MS out to troubleshoot (yes they were on site) came down to an old version of UPHCLEAN. So make sure your at the latest and greatest version of UPHCLEAN.
  • | Post Points: 20
Top 150 Contributor
Points 2,098
I have 1.6d running on w2k3 sp1 cps4.0. Looks like 2.0 is getting close...
  • | Post Points: 20
Guest replied on Fri, Mar 9 2007 5:01 PM
I am also running the newest version of UPHC and still no luck.
  • | Post Points: 20
Top 75 Contributor
Points 2,624
Have you tried Process Explorer and Process Monitor ? They might be able to shed some light on this.

Also, if we could get some user dumps of the crashes, we might be able to see what caused it. If this is somethign you guys would like to keep working at let me know. I wouldnt mind taking a look at the dumps, its great practice.
--Mike
  • | Post Points: 20
Not Ranked
Points 275
Still no luck. Any of you found anything?
  • | Post Points: 20
Not Ranked
Points 210
I have been working with Microsoft for the past month on this. We've tried a few things, but still no luck. I will post any progress.
Jeff Venier
Network Administrator
  • | Post Points: 20
Not Ranked
Points 300
We're having the same issues. We have 12+ PS 4.0 R03, win2k3 servers. The issues only started when we implemented Mandatory profiles and Flex Profiles. Latest version of UPHC too.

6/13/2007 11:55 AM : Application Jun 13 2007 11:55:50 %Application: Application Error : Faulting application pnagent.exe, version 10.0.52110.0, faulting module kernel32.dll, version 5.2.3790.2756, fault address 0x0002dd9f.

6/13/2007 11:55 AM : Application Jun 13 2007 11:54:59 %Application: Application Hang : Hanging application iexplore.exe, version 6.0.3790.1830, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

These are just examples, we get errors in Excel, Word, PNAgent, Internet Explorer, Adobe etc. It doesn't seem to affect the users either, strange...

Help! Any ideas????

Thanks
  • | Post Points: 20
Not Ranked
Points 5
Amal replied on Wed, Oct 24 2007 12:23 PM
Hi Jeff and all,
I have the same issue and it is very critical to be solved.
Did you solve it with MS?
Thanks
Amal
  • | Post Points: 5
Not Ranked
Points 5
I have this same issue and users are actually getting kicked off the citrix servers. Let me know what you find out from microsoft.
  • | Post Points: 5
Page 1 of 2 (17 items) 1 2 Next > | RSS