Users getting disconnected, in the Citrix XenApp / Presentation Server forum on BrianMadden.com
Brian Madden Logo
Your independent source for desktop virtualization, consumerization, and enterprise mobility management.

Users getting disconnected, in the Citrix XenApp / Presentation Server forum on BrianMadden.com

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 0 Followers

Guest posted on Tue, Apr 17 2007 8:10 AM
I could sure use some help with this one. Users are being disconnected after being idle for anywhere from 2 to 20 minutes. No rhyme or reason for the timing out that I can find. If the user is not there to hit any key they get thrown out of Citrix.

Users receive Application Popup: Idle timer expired : sessions has been idle over its time limit. Logoff will start in 2 minutes. The users are coming over a WAN through CAG 4.5 double hop to WI 4.0 and PS 4.0. This is what I have done so far:

On PS - TS Override User settings; Active session limit - never
ICA-TCP Connection Timeout Setting - No connection timeout
Disconnect Time out and Idle Timeout settings are greyed out

Reg hacks HKLM\system\Currentcontrolset\services\tcpip\parameters
KeepAliveTime=dword:0000ea60
keepAliveInterval=dword:000003e8
tcpmaxdataretransmissions=dword:10

HKLM\system\currentcontrolset\control\citrix
Icaenablekeepalive=dword:00000001
icakeepaliveInterval=dword:0000003

HKLM\system\currentcontrolset\control\terminalserver
keepaliveenable=dword:1

On WI edited the web.config sessionState timeout="1440"
IIS edited CitrixWebInterfaceAppPool idle time 1440

After doing the above users are still timing out but not being completely thrown out of Citrix just the applications. They go back to the WI and can log back into the appliction. I have researched until my eyes are blurry. Any help would be greatly appreciated. Just to throw in the network coming in is NMCI for those of you familar with the Navy.

Caroline

  • | Post Points: 20

All Replies

Top 500 Contributor
Points 694
Porky replied on Tue, Apr 17 2007 8:38 AM
Perhaps I'm on the wrong track concerning your problem, but if if I understood it correctly you can run the tscc.msc from the start|run you'll open the terminal server configuration console. Under the sessions tab for the respective protocol you can adjust teh connection settings.
Hope this helps.
  • | Post Points: 20
Guest replied on Tue, Apr 17 2007 9:08 AM
That did get us thinking. The idle time was greyed out and had 15 minutes. Due to DoD lockdown procedures there are some things we are not suppose to change. We went into group policy and made changes there. The idle time is still greyed out but is now never. I will contact the NMCI users to see if this helped. The weird thing is we have other networks coming in and not having timeout issues. I wanted to run this to the ground before I approached the NMCI IT people. Thanks for your help.
  • | Post Points: 5
Page 1 of 1 (3 items) | RSS